This project has moved. For the latest updates, please go here.
1

Resolved

The specified store provider cannot be found in the configuration, or is not valid.

description

I try to run the BookLibrary, but the Debugger stops at the constructor of BookLibraryEntities with the exception:
 
The specified store provider cannot be found in the configuration, or is not valid.
 
I unzipped WpfApplicationFramework-2.0.0.400 to d:\WpfApplicationFramework-2.0.0.400, compiled the solution, set BookLibrary.Presentation as startup project, and started the debugger.
 
How can I solve this problem?

file attachments

comments

jbe2277 wrote Feb 6, 2012 at 7:44 PM

Thank you for submitting this issue.

I believe that the SQL Server Compact 3.5 database installation is missing on your machine.
You can download it here: http://www.microsoft.com/download/en/details.aspx?id=5783

Please note that the SQL Server Compact 3.5 is part of the Visual Studio 2010 installation. But it is not included in the Visual Studio 11 Developer Preview.

wrote Feb 8, 2012 at 6:36 AM

pappasa wrote Feb 8, 2012 at 6:36 AM

As you can see from the attached file, Microsoft SQL Server 3.5 SP2 ENU is installed.

I also pasted the Error List from Visual Studio. When I double click on it, it just opens BookLibraryModel.edmx, which does not give me a clue, what the problem might be.

jbe2277 wrote Feb 8, 2012 at 5:59 PM

I haven’t seen this error before. The error from the VS error list targets the following line in BookLibraryModel.edmx:

<Schema Namespace="BookLibraryModel.Store" Alias="Self" Provider="System.Data.SqlServerCe.3.5" ProviderManifestToken="3.5" …>

I just can guess that the SQL Server Compact SP2 might not be properly installed.

mfmanca wrote Feb 15, 2012 at 8:39 AM

I was having the smae issue and I can confirm it was enough for me to uninstall and reinstall SQL Server Compact 3.5 SP2 from the source linked by jbe2277.

wrote Feb 22, 2013 at 12:43 AM

wrote Aug 25, 2013 at 1:14 PM